Невозможно запустить apt-get update / upgrade в Ubuntu 17.10

Мой первый пост и вопрос к форуму. Я относительно новый пользователь в Ubuntu и обновил с 16.04 до 17.10. При попытке установить сканер (HP Deskjet All-in-one 2135) установка драйвера не удалась (обновление с использованием приложений HPLIP и SimpleScan в Ubuntu). выполните команду "sudo apt-get upgrade" из-за следующих ошибок.

[email protected]:~$ sudo apt-get update 
    Hit:1 http://in.archive.ubuntu.com/ubuntu artful InRelease 
    Hit:2 http://security.ubuntu.com/ubuntu artful-security InRelease 
    Hit:3 http://in.archive.ubuntu.com/ubuntu artful-updates InRelease 
    Hit:4 http://in.archive.ubuntu.com/ubuntu artful-backports InRelease 
    Reading package lists... Done  

[email protected]:~$ sudo apt-get upgrade 
Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
You might want to run 'apt --fix-broken install' to correct these. 
The following packages have unmet dependencies:  libsnmp30:i386 : Depends: libperl5.26:i386 (>= 5.26.0~rc1) but it is not installed 
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Я попытался запустить sudo apt --fix-broken install, как указано, и сообщение выглядит следующим образом:

[email protected]:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  a11y-profile-manager-indicator account-plugin-facebook account-plugin-flickr
  account-plugin-google accountsservice-ubuntu-schemas
  accountsservice-ubuntu-touch-schemas address-book-service app-install-data
  apparmor-easyprof apparmor-easyprof-ubuntu biometryd-bin click
  click-apparmor content-hub ethtool evolution-data-server-online-accounts
  evolution-data-server-utouch folks-common g++-6 gconf2
  gir1.2-appindicator3-0.1 gir1.2-appstreamglib-1.0 gir1.2-click-0.4
  gir1.2-gee-0.8 gir1.2-gusb-1.0 gnome-system-log history-service
  indicator-network indicator-transfer indicator-transfer-download-manager
  intel-gpu-tools liba11y-profile-manager-0.1-0 liba11y-profile-manager-data
  libaccount-plugin-1.0-0 libaccount-plugin-facebook libaccount-plugin-flickr
  libaccount-plugin-generic-oauth libaccount-plugin-google libaccounts-qt5-1
  libandroid-properties1 libass5 libbiometryd1 libblas-common
  libboost-log1.62.0 libboost-program-options1.62.0 libboost-regex1.62.0
  libboost-system1.61.0 libcamel-1.2-59 libclick-0.4-0 libconnectivity-qt1
  libcontent-hub-glib0 libcontent-hub0 libdbus-cpp5 libdirectfb-1.2-9
  libebook-1.2-16 libebur128-1 libertine-xmir-tools libertined libevent-2.0-5
  libfolks-eds25 libfolks25 libgflags2.2 libgflags2v5 libgfortran3
  libgmime-2.6-0 libgoogle-glog0v5 libgtkglext1 libgtkspell3-3-0
  libgtop-2.0-10 libhardware2 libhistoryservice0 libhud2 libhunspell-1.4-0
  libhybris libhybris-common1 libindicator-transfer0
  libjavascriptcoregtk-1.0-0 libleveldb1v5 liblibertine1 liblightdm-qt5-3-0
  liblivemedia57 libllvm4.0 libmedia1 libmediascanner-2.0-4 libmicrohttpd10
  libmiral2 libmircookie2 libmirplatform15 libmirplatform16 libmirserver43
  libmirserver45 libmission-control-plugins0 libnm-glib-vpn1 libnm-gtk-common
  libnma-common libnss-resolve libntfs-3g871 libonline-accounts-client1
  libonline-accounts-daemon1 libonline-accounts-qt1 libopencv-calib3d2.4v5
  libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5
  libopencv-highgui2.4-deb0 libopencv-imgproc2.4v5 libopencv-objdetect2.4v5
  libopencv-video2.4v5 liboxideqt-qmlplugin liboxideqtcore0 liboxideqtquick0
  libpcre16-3 libperl5.24 libpkcs11-helper1 libpoppler-qt5-1 libpoppler64
  libpython3.5 libqdjango-db0 libqgsttools-p1 libqmenumodel0 libqofono-qt5-0
  libqpdf17 libqt5concurrent5 libqt5contacts5 libqt5feedback5
  libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediaquick-p5
  libqt5multimediawidgets5 libqt5opengl5 libqt5organizer5 libqt5positioning5
  libqt5printsupport5 libqt5quicktest5 libqt5sensors5 libqt5systeminfo5
  libqt5test5 libqt5versit5 libqt5webkit5 libqt5xmlpatterns5
  libsignon-extension1 libsignon-plugins-common1 libsignon-qt5-1 libssl-dev
  libssl-doc libstdc++-6-dev libsystemsettings1 libtelepathy-qt4-2
  libtelepathy-qt5-0 libthumbnailer-qt1.0 libtracker-sparql-1.0-0
  libtrust-store2 libubuntu-application-api3
  libubuntu-download-manager-client1 libubuntu-download-manager-common1
  libubuntu-location-service3 libubuntu-platform-hardware-api3
  libubuntumetrics5 libudm-common1 libudm-priv-common1 libunity-action-qt1
  libunwind8 liburcu4 libusermetricsinput1 libusermetricsoutput1
  libwebkitgtk-1.0-0 libwebpmux2 libx265-110 linux-headers-4.10.0-28
  linux-headers-4.10.0-28-generic linux-headers-4.10.0-30
  linux-headers-4.10.0-30-generic linux-image-4.10.0-28-generic
  linux-image-4.10.0-30-generic linux-image-extra-4.10.0-28-generic
  linux-image-extra-4.10.0-30-generic mediascanner2.0
  mir-client-platform-mesa5 mir-graphics-drivers-desktop
  mir-platform-graphics-mesa-kms12 mir-platform-graphics-mesa-kms13
  mir-platform-graphics-mesa-x12 mir-platform-graphics-mesa-x13
  mir-platform-input-evdev6 mir-platform-input-evdev7 network-manager-openvpn
  onboard onboard-common onboard-data openvpn overlay-scrollbar
  overlay-scrollbar-gtk2 oxideqt-codecs perl-modules-5.24
  plainbox-provider-checkbox plainbox-provider-resource-generic
  plainbox-secure-policy policykit-unity8 python3-apparmor
  python3-apparmor-click python3-checkbox-support python3-click-package
  python3-guacamole python3-jinja2 python3-libapparmor python3-libertine
  python3-padme python3-plainbox python3-psutil python3-pyasn1
  python3-pyparsing python3-xlsxwriter qmenumodel-qml qml-module-biometryd
  qml-module-io-thp-pyotherside qml-module-ofono
  qml-module-pamauthentication0.1 qml-module-qmltermwidget1.0
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings
  qml-module-qtfeedback qml-module-qtgraphicaleffects qml-module-qtmultimedia
  qml-module-qtqml-models2 qml-module-qtqml-statemachine
  qml-module-qtquick-layouts qml-module-qtquick-window2
  qml-module-qtquick-xmllistmodel qml-module-qtquick2 qml-module-qtsysteminfo
  qml-module-qttest qml-module-ubuntu-connectivity
  qml-module-ubuntu-onlineaccounts qml-module-ubuntu-onlineaccounts-client
  qml-module-ubuntu-onlineaccounts2 qml-module-ubuntu-performancemetrics
  qml-module-ubuntu-thumbnailer0.1 qmlscene qtcontact5-galera
  qtdeclarative5-accounts-plugin qtdeclarative5-dev-tools
  qtdeclarative5-gsettings1.0 qtdeclarative5-qtquick2-plugin
  qtdeclarative5-test-plugin qtdeclarative5-ubuntu-content1
  qtdeclarative5-ubuntu-download-manager0.1 qtdeclarative5-ubuntu-telephony0.1
  qtdeclarative5-unity-action-plugin qtdeclarative5-unity-notifications-plugin
  qtubuntu-desktop rename repowerd repowerd-data signon-keyring-extension
  signon-plugin-oauth2 signon-ui signon-ui-service signon-ui-x11 signond
  sni-qt sqlite3 suru-icon-theme telepathy-mission-control-5 telephony-service
  thumbnailer-service tone-generator ubuntu-app-launch-tools
  ubuntu-application-api3-desktop ubuntu-application-api3-test
  ubuntu-download-manager ubuntu-mobile-icons ubuntu-ui-toolkit-theme
  unity-accessibility-profiles unity-control-center-signon unity-plugin-scopes
  unity-scope-gdrive unity-scope-mediascanner2 unity-system-compositor
  usermetricsservice xdiagnose xmir xml-core
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libperl5.26:i386
The following NEW packages will be installed:
  libperl5.26:i386
0 upgraded, 1 newly installed, 0 to remove and 56 not upgraded.
3 not fully installed or removed.
Need to get 0 B/3,157 kB of archives.
After this operation, 16.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 282373 files and directories currently installed.)
Preparing to unpack .../libperl5.26_5.26.0-8ubuntu1_i386.deb ...
Unpacking libperl5.26:i386 (5.26.0-8ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libperl5.26_5.26.0-8ubuntu1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libperl5.26/changelog.Debian.gz', which is different from other instances of package libperl5.26:i386
Errors were encountered while processing:
 /var/cache/apt/archives/libperl5.26_5.26.0-8ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Я также попробовал опцию autoremove, и возвращаемое сообщение выглядит следующим образом:

[email protected]:~$ sudo apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libsnmp30:i386 : Depends: libperl5.26:i386 (>= 5.26.0~rc1) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Пожалуйста, помогите мне решить эту проблему. Заранее большое спасибо.

0 ответов

Другие вопросы по тегам