Qt - это инфраструктура приложений, изначально созданная Trolltech и в настоящее время управляемая Digia. Рабочий стол KDE использует инфраструктуру Qt для своих приложений.
1 ответ

Как сделать кросс-компиляцию пакета Qt для armhf с помощью sbuild?

У меня есть приложение Qt, которое я хотел бы кросс-компилировать для armhf. Я установил sbuild chroot с помощью следующей команды: mk-sbuild --target armhf trusty Тем не менее, когда я бегу debuild -S и затем попытаться собрать пакет, я сталкиваюсь…
21 мар '15 в 20:23
3 ответа

Как установить необходимые пакеты Qt для сборки ядра на 14.04?

Я собираюсь скомпилировать ядро ​​на 64-битной Ubuntu 14.04, поэтому я начну с установки пакетов, которые мне нужны: sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev wget libncurses5 libncurses5-dev qt4-dev-tool…
1 ответ

Невозможно cmake mirall, потому что не удалось найти Qt5Keychain (отсутствует: QTKEYCHAIN_LIBRARY)

Я пытаюсь скомпилировать Mirall на моем Ubuntu 14.04.1 LTS. Вот команда, которую я использую: cmake -DCMAKE_BUILD_TYPE="Debug" ../mirall -DCSYNC_BUILD_PATH=/home/jnbdz/Projects/ownCloudDesktop/ocsync-build -DCSYNC_INCLUDE_PATH=/home/jnbdz/Projects/o…
20 сен '14 в 23:12
0 ответов

Как заставить приложения Qt использовать стиль GTK+ в Xubuntu 15.04?

Я сейчас использую Ubuntu 15.04, и приложения Qt, такие как qBittorrent и Clementine, выглядят так, как будто они были приложениями GTK+, они используют значки и стиль системы. Но я установил Xubuntu на другой компьютер и не происходит то же самое. …
10 май '15 в 12:11
0 ответов

Проблема с установкой Qt5.3

Я пытаюсь установить Qt5.3 в мою Ubuntu 14.04(64 бит). В то время как процесс установки запускался внезапно, он отображал некоторые запросы и отображал несколько сообщений об ошибках, как показано ниже: Error during installation process (qt.53.doc):…
16 май '15 в 17:59
1 ответ

Ubuntu SDK: Как я могу использовать PyQt для разработки приложений Ubuntu Touch?

Я слышал, что это возможно, вы можете дать мне несколько советов о том, как это сделать?
15 ноя '14 в 19:54
0 ответов

Приложения не работают из-за неработающей библиотеки Qt: отсутствует XCB (Ubuntu 17.10)

Молодой разработчик в обучении Я новичок в Ubuntu, и у меня возникают проблемы с работой... Действительно, некоторые приложения не запускаются из-за дефекта библиотеки. Похоже, что эти приложения зависят от библиотек Qt. Для нужд моих сетевых классо…
1 ответ

Как построить против qt 5.3.1?

Попытка собрать qt-creator v3.2.2 из исходного кода на Ubuntu 14.10. Не удается. Qmake не может найти qt5.3.1 $ qmake -r ... Project WARNING: QmlDesigner plugin has been disabled. Project WARNING: This plugin requires Qt 5.3.1 or newer. ... Project …
25 ноя '14 в 06:42
1 ответ

QStrings изменчивы?

В питоне; Строки не являются изменяемыми, насколько я знаю. Чтобы изменить строку в Python, вам нужно будет создать новый объект. Это то же самое для QString?
01 дек '14 в 16:42
1 ответ

Как установить / использовать более старую версию Qt

Я строю проект, который ретранслирует программу с открытым исходным кодом, которая была создана давно с использованием старой версии Qt (V3.3). Есть ли способ установить более старую версию? или обновление программы?
24 дек '16 в 04:18
1 ответ

Программа не может найти libQt3Support.so.4

Я пытаюсь запустить программу, но программа жалуется, что error while loading shared libraries: libQt3Support.so.4: cannot open shared object file: no such file or directory Я вижу, что остальные необходимые библиотеки Qt есть, только эта не найдена…
03 дек '14 в 20:24
1 ответ

Как настроить Qt для доступа к стандартным ресурсам / темам значков?

Я занимаюсь разработкой приложения с использованием Qt design и борюсь с механизацией тем ресурсов значков. По сути, я хотел бы получить доступ ко всем стандартным значкам, когда я нажимаю выбрать ресурс. Где на земле это стандартный значок ресурса.…
22 авг '14 в 23:22
0 ответов

Как модули / классы Qt распределяются между пакетами Ubuntu?

Например, я знаю, что мне нужно core зависимость или network один. Другими словами, у меня есть следующие строки в файле проекта QBS Depends { name: "Qt.core" } Depends { name: "Qt.network" } Теперь мой вопрос: как мне определить, какие пакеты мне н…
08 окт '18 в 14:30
1 ответ

Невозможно выполнить консольную программу QT в Ubuntu

Произошла ошибка. Starting /media/milo/DATA1/Milo/C++/build-test-Desktop-Debug/test... Cannot execute '/media/milo/DATA1/Milo/C++/build-test-Desktop-Debug/test': Permission denied /media/milo/DATA1/Milo/C++/build-test-Desktop-Debug/test exited with …
21 июн '15 в 11:41
0 ответов

Как я могу установить библиотеку qt-mt (многопоточный Qt) в Ubuntu 14.04?

Я пытаюсь установить программное обеспечение для камеры Mightex, и первый шаг - запустить ./configure файл, после получения большого количества сообщений, где он проверяет библиотеки, происходит сбой со следующим: checking if Qt is multi-threaded...…
1 ответ

VLC не запускается в Ubuntu 14.04 из-за ошибки Qt

Это ошибка, которую я получаю, пытаясь открыть VLC VLC media player 2.1.4 Rincewind (revision 2.1.4-0-g2a072be) [0x9e37910] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface. [0x9ec11d8] skins2 interface er…
02 янв '15 в 18:13
0 ответов

Как запустить приложение Qt, скомпилированное и связанное с Qt 4.8.4 в системе с интегрированным Qt 4.8.6

Я написал приложение, используя Qt 4.8.4. Теперь я приобрел новый ПК и установил Kubuntu 14.10 на основе Qt 4.8.6. Для разработки своего приложения я собрал Qt 4.8.4 из исходного кода, используя make install и это прошло успешно. Но я получаю следую…
03 янв '15 в 09:05
1 ответ

Установка андроид студии

Когда я пытался установить андроид студию на мою систему Ubuntu 14.04 LTS, opt каталог, как указано на Clayton (пользователь Ubuntu), но я не мог установить его соответствующим образом. Распакуйте zip-архив студии android в каталог загрузок Затем от…
03 янв '15 в 19:18
0 ответов

Невозможно установить устройство Airtel 4G LTE (устройство USB Dongle) в Ubuntu 16.04(64 бита)

Недавно я установил Ubuntu 16.04 и пытаюсь установить устройство Airtel 4G LTE, но оно дает мне следующие ошибки при установке Также не показывает устройства в конце. Но в проводнике файлов обнаруживается устройство и отображается папка Airtel. Може…
20 ноя '18 в 13:02
0 ответов

Как установить qt по умолчанию на 5.0 или выше?

Я установил последнюю версию qt, чтобы установить eric6. Другая зависимость - pyqt. Когда я бегу python configure.py Я получаю следующую ошибку: qmake: could not exec '/usr/lib/i386-linux-gnu/qt4/bin/qmake': No such file or directory Error: PyQt5 re…
24 янв '17 в 18:58