Раздражает мерцание в 16.04 LTS - Chrome

Я обновил с 4.4.0 до 4.4.8, а затем 4.5.2 на Ubuntu 16.04 LTS 64-bit, и это все еще происходит.

В 4.5.2 это даже более часто, и в основном в Chrome (еще не пробовал Firefox или Opera). Каждый раз, когда я открываю новую веб-страницу. Есть ли способ исправить это, или это ошибка?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Приветствия.

11 ответов

Решение

После некоторых исследований я нашел решение этой проблемы. Это работает для меня сейчас.

Я отключил аппаратное ускорение для моего браузера из

Settings > Advance Settings > System > uncheck the hardware acceleration

Надеюсь, это работает на вашей машине.


я использую google-chrome-stable Version 50.0.2661.94 (64-bit) на Ubuntu 16.04

-----РЕДАКТИРОВАТЬ----

Если вы столкнулись с задержкой прокрутки и разрывом экрана. Сделайте, как предложено Amos Folarin в комментарии ниже:

Идти к: chrome://flags/#smooth-scrolling и включите его.

191

У меня была та же проблема, похоже, наконец-то работает установка растеризации графического процессора на "Принудительное включение для всех слоев":

https://ask-ubun tu.ru/images/1643fab8b3b478b9e6d9ea9eafc81820fdadc785.png

159

Я исправил это следующим образом:

sudo apt-get purge xserver-xorg-video-intel

затем перезагрузите компьютер. Это связано с тем, что драйверы Intel перешли на режим настройки. Для получения дополнительной информации см. Этот комментарий в ветке ошибок Chromium.

44

Откройте терминал и введите эту команду:

sudo nano /usr/share/applications/chromium-browser.desktop

и прокрутите вниз, пока не дойдете до этой строки:

Exec= chromium-browser

Затем добавьте эти два параметра

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Нажмите Ctrl+O для сохранения и Ctrl+X для выхода.

Затем введите эту команду:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

и добавить эти строки

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Нажмите Ctrl+O, затем Ctrl+X.

Откройте Chromium и напишите в адресную строку: chrome://flags/ и войти.

  • Enable-ноль-копия
  • Включить переопределение списка программного рендеринга
  • Включить отображение 2D списка холста

Наконец, откройте настройки Chrome и нажмите:

  • Используйте аппаратное ускорение, когда доступно
38

Ни один из этих ответов, казалось, не помог мне. То, что я в итоге сделал, что, кажется, исправило это (моя ссылка была на этот сайт http://www.bang-olufsen.com/ который мерцал как CRAZY, и теперь он работает плавно), это:

1.- Навигация в chrome://gpu/, Вот что он показал:

https://ask-ubuntu.ru/images/7b200727bab4abaa26be0e0fcad7ccd9b350a658.png

2.- Я пытался решить проблемы по одной. В моем случае включение этих флагов исправило некоторые из них: GPU rasterization, Override software rendering list, Тогда это показало так:

https://ask-ubuntu.ru/images/6ba45b633bc69830b6ba9819cf73fe506d1196a8.png

3.- Я отредактировал лаунчер рабочего стола и добавил параметры --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers,

4.- После этого проблем больше не обнаружено, все отображается как "аппаратное ускорение" и, что более важно, больше не мерцает:

https://ask-ubuntu.ru/images/e43471aa9db25f06cc7aa4ae304a38721037bebe.png

Если вы сначала добавите параметры в панель запуска, список проблем должен быть короче, и, вероятно, будет легче выяснить, какие флаги помогут вам в решении оставленных вами проблем.

26

В версии Chrome 51.0.2704.103 (64-разрядная версия) флаги

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

больше не работают

Лучший способ сделать это - вернуться к Chrome 50 (версия 50.0.2661.86 (64-разрядная версия)). Вот инструкция, как сделать шаг назад: как мне понизить Google Chrome?

Важно то, что мы оказываем давление на Google, чтобы решить эту проблему, голосуем за ошибку в Chromium и на странице продукта Google:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/

7
chrome://flags/ > GPU rasterization > Enable,

Это наконец-то сработало для меня! Нашел его внизу этой формы Google! https://productforums.google.com/forum/

5

Я думаю, что нашел решение:

флаги --disable-gpu-driver-bug-обходные пути --enable-native-gpu-memory-buffers, а также enable-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection
4

Попробуйте загрузить с некоторыми опциями GPU:

--disable-gpu-driver-bug-обходные пути --enable-native-gpu-memory-buffers

После того, как вы попробуете это, вы также можете поиграть с некоторыми настройками рендеринга в about://flags и посмотреть, поможет ли что-нибудь там, но большая часть моих мерцаний рендера была решена двумя флагами командной строки. Если у вас есть файл запуска.desktop, добавьте эти флаги в верхнюю запись Exec перед "%U". Вы также можете добавить их в другие записи Exec, чтобы флаги применялись ко всем режимам запуска.

2

Я обнаружил, что настоящие исправления не работают для текущей версии Chrome, дальнейшие вещи должны быть изменены (по крайней мере, для моей настройки).

Я могу подтвердить, что это работает (удаляет как мерцание, так и разрыв) - благодаря https://bugs.chromium.org/p/chromium/issues/detail?id=606152

Компьютер: XPS13 9343 Графика: 00:02.0 Контроллер, совместимый с VGA: Intel Corporation Broadwell-U Integrated Graphics (версия 09) Версия Chrome: Версия 54.0.2840.100 (64-разрядная версия)

настройки

1) Проверьте сообщения об ошибках до и после настроек конфигурации ниже

  • хром: // ГПУ
  • сделать скриншот, чтобы вы могли сравнить после.

2) Редактировать (для хрома): /usr/share/applications/google-chrome.desktop или для (хром): /usr/share/applications/chromium-browser.desktop

  • Добавьте флаги --disable-gpu-driver-bug-обходные пути --enable-native-gpu-memory-buffers
  • строка должна выглядеть так: Exec=/usr/bin/google-chrome-stable --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers %U

3) sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf добавьте это (вам может понадобиться создать файл):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

4) Настройки Chrome flags: chrome: // flags:

  • Включить (растеризатор нулевого копирования): chrome: // flags / # enable-zero-copy
  • Включить (включить отображение списка 2d canvas): chrome: // flags / # enable-display-list-2d-canvas
  • Включить ("Переопределить список программного рендеринга"): chrome://flags/# ignore-gpu-blacklist
  • Включить "Отображение списка 2D-холст"): chrome://flags/#enable-display-list-2d-canvas
  • Включить (флаг chrome для плавной прокрутки в Linux): chrome: // flags / # smooth-scrolling

5) Я сохранил Настройки Chrome> Дополнительно> Использовать аппаратное ускорение, когда доступно [держите флажок]. Если снять этот флажок, это действительно ухудшает производительность (хотя и уменьшает мерцание, но не разрывает), описанные выше варианты работают намного лучше для меня.

6) Перезагрузите компьютер.

7) Сравните настройки. хром: // ГПУ

Это полностью исключило мерцание и слезы для меня.

2

Отключение аппаратного ускорения приведет к снижению производительности вашего браузера для страниц с анимацией и другими ресурсоемкими задачами.

Однако, если у вас нет установленного графического процессора в вашей системе, то подход отключения аппаратного ускорения, предложенный sgiri, является лучшим для вас.

Но у меня на ноутбуке установлена ​​графическая карта NVidia, и я использую настольную ОС Ubuntu. Поэтому я установил проприетарный двоичный драйвер (версия 352.63). Это сработало для меня, надеюсь, будет работать и в вашей системе Ubuntu.

1
Другие вопросы по тегам