Не удалось запустить демон xrdp, возможно, адрес уже используется

Нужна помощь в решении этой проблемы.

ОС: Ubuntu 20.04 LTS

Ошибка: не удалось запустить демон xrdp, возможно, адрес уже используется.

journelctl -xe

    -- A start job for unit xrdp.service has begun execution.
--
-- The job identifier is 1785.
okt 23 12:01:29 Ubutu20 xrdp-sesman[3636]: (3636)(140566295258688)[INFO ] listening to port 3350 on 127.0.0.1
okt 23 12:01:29 Ubutu20 xrdp[3650]: (3650)(140065546684224)[INFO ] address [0.0.0.0] port [3389] mode 3
okt 23 12:01:29 Ubutu20 xrdp[3650]: (3650)(140065546684224)[INFO ] listening to port 3389 on 0.0.0.0
okt 23 12:01:29 Ubutu20 xrdp[3650]: (3650)(140065546684224)[ERROR] trans_listen_address failed
okt 23 12:01:29 Ubutu20 xrdp[3650]: (3650)(140065546684224)[DEBUG] Closed socket 7 (AF_VSOCK cid -1 port -1)
okt 23 12:01:29 Ubutu20 xrdp[3650]: (3650)(140065546684224)[ERROR] Failed to start xrdp daemon, possibly address already in use.
okt 23 12:01:29 Ubutu20 systemd[1]: xrdp.service: Control process exited, code=exited, status=1/FAILURE
-- Subject: Unit process exited
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- An ExecStart= process belonging to unit xrdp.service has exited.
--
-- The process' exit code is 'exited' and its exit status is 1.
okt 23 12:01:29 Ubutu20 systemd[1]: xrdp.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- The unit xrdp.service has entered the 'failed' state with result 'exit-code'.
okt 23 12:01:29 Ubutu20 systemd[1]: Failed to start xrdp daemon.
-- Subject: A start job for unit xrdp.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/suppor

netstat -epl

sudo netstat -epl | grep 3389
sandesh@Ubutu20:~$

1 ответ

Отредактируйте файл

/etc/xrdp/xrdp.ini

Измените параметры следующим образом:

      port = tcp: //: 3389

use_vsock = false

Затем перезапустите службу xrdp: sudo systemctl restart xrdp

Объяснение проблемы :

металлефти:

use_vsock=yes больше не является предпочтительным, но инструмент MS все еще использует этот переключатель. Сообщите об этом автору инструмента и попросите его исправить.

PS функция vsock разработана ребятами из MS. Мы, команда xrdp, объединили это, но если ребята из MS не будут поддерживать vsock, он может быть удален в будущем. Мы приветствуем постоянный вклад от ребят из MS!

Другие вопросы по тегам