Сервер Ubuntu 12.04 не разрешает локальное доменное имя
После обновления apt-get этим утром мой веб-сервер Ubuntu 12.04 больше не разрешает доменное имя, размещенное на нем.
Я также получил сообщение об ошибке:
"resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything."
Я обнаружил, что NetworkManager не заполняет resolv.conf, но предоставленные там решения не решили проблему.
Создание символической ссылки фактически приводило к тому, что веб-сайты загружались очень медленно, поэтому я предполагаю, что какой-то (обратный?) Поиск DNS не работает, когда я создаю символическую ссылку.
1 ответ
Запуск "dpkg-conconfigure resolvconf" устанавливает символическую ссылку /etc/resolv.conf -> ../run/resolvconf/resolv.conf. После этого вы должны перезагрузиться.
Если веб-сайты начинают медленно загружаться, это может означать, что сервер имен, указанный в resolv.conf, не отвечает. Glibc resolver(3) пробует первый из перечисленных серверов имен и ждет пять секунд, прежде чем пробовать следующий из перечисленных серверов имен.
Также попробуйте закомментировать "dns=dnsmasq" в /etc/NetworkManager/NetworkManager.conf и запустить "restart network-manager". Это отключает локальный экземпляр dnsmasq, контролируемый NetworkManager, что исключает его как возможную причину вашей проблемы.
Если веб-сайты не начинают медленно загружаться, но загружаются медленно после запуска, то, скорее всего, это не проблема разрешения имен.