403 Запрещено при изменении корня документа Apache2

Я бегу Mint 17, и я изменил свой /etc/apache2/sites-available/000-default.conf файл к следующему:

<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin [email protected]
    DocumentRoot /home/vg/www

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Выход из $ ls -al на уровне моего домашнего каталога:

drwxr-xr-x  2 vg   vg   4096 Aug 29 12:44 www

И внутри www каталог:

drwxr-xr-x  2 vg vg 4096 Aug 29 12:44 .
drwxr-xr-x 21 vg vg 4096 Aug 29 12:43 ..
-rwxrwxr-x  1 vg vg   22 Aug 29 12:44 info.php

Когда я указываю Firefox на localhost/info.php, я получаю 403, разрешение отклонено.

info.php просто содержит:

<?php
    phpinfo();
?>

Есть идеи?

1 ответ

Решение

В Ubuntu Apache конфигурация по умолчанию запрещает случайные корни виртуальных сайтов по умолчанию.

Отредактируйте /etc/apache2/apache2.conf и следующие строки (желательно после блоков каталога по умолчанию, чтобы можно было отслеживать местоположения, которые вы включили для корня сайта)

<Directory /home/vg/www>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

Перезагрузите Apache, и ошибка должна исчезнуть, и вы должны снова увидеть ваш сайт.

Другие вопросы по тегам