Ключевые ошибки GPG для старых версий

W: GPG error: http  //archive.ubuntu.com jaunty Release: The following signatures were invalid: NODATA 2
W: Failed to fetch http:  //archive.ubuntu.com/ubuntu/dists/jaunty-updates/Release.gpg  Error reading from server - read (104 Connection reset by peer) [IP: 91.189.92.170 80]

W: Failed to fetch http:  //archive.ubuntu.com/ubuntu/dists/jaunty-updates/universe/i18n/Translation-en_IN.bz2  Error reading from server - read (104 Connection reset by peer) [IP: 91.189.92.170 80]

W: Failed to fetch http:  //archive.ubuntu.com/ubuntu/dists/jaunty-updates/multiverse/i18n/Translation-en_IN.bz2  Error reading from server - read (104 Connection reset by peer) [IP: 91.189.92.170 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.

4 ответа

Что касается предупреждений "Не удалось получить", то это связано с 18-месячным EOL Jaunty. Репозитории пакетов перенесены на другой сервер - из archive.ubuntu.com в old-releases.ubuntu.com, Попробуйте изменить ваш /etc/apt/sources.list соответственно, как показано в sources.list на этой странице:

https://help.ubuntu.com/community/EOLUpgrades/Jaunty

Вам не нужно фактически обновлять ваш релиз, просто измените источники APT.

Ubuntu 9.04 aka "Jaunty" была завершена с прошлого месяца. Я подозреваю, что ошибка, которую вы видите, связана с этим...

Вы должны обновить свою систему до более новой версии, чтобы гарантировать получение обновлений безопасности.

Попробуй это

  • Восстановите ключи по умолчанию в Synaptic (Настройки -> Администрирование -> Менеджер пакетов Synaptic)

  • В Synaptic Package Manager зайдите в Настройки -> Репозитории

  • Откроется исходный код программного обеспечения, перейдите на вкладку "Аутентификация" и нажмите "Восстановить настройки по умолчанию"

альтернативный текст

А затем введите следующее в терминале.

sudo apt-get clean all
sudo apt-get upodate

Я надеюсь, что это решит вашу проблему. Если у вас есть какие-либо проблемы, дайте мне знать через комментарии.

Я попытался в соответствии с инструкциями, но он дал следующие ошибки при выполнении восстановления по умолчанию, он показывает нулевое значение, так как во время обновления с 9.04 до 9.10 в этом процессе я исключил более ранние ключи;-

Как я должен получить ключи GPG для Jaunty

Нажмите http: //archive.ubuntu.com jaunty-updates / universe Sources
Нажмите http: //archive.ubuntu.com jaunty-updates / main Sources
Нажмите http: //archive.ubuntu.com jaunty-updates / multiverse Sources
Получил 598B за 6 секунд (88B / s)
W: Ошибка GPG: http: //security.ubuntu.com Выпуск jaunty-security: Недопустимые следующие подписи: NODATA 2 W: Ошибка GPG: http: //archive.ubuntu.com Выпуск jaunty: Недопустимые следующие подписи: NODATA 2 W: ошибка GPG: http: //archive.ubuntu.com jaunty-updates Выпуск: следующие недействительные подписи: NODATA 2 W: не удалось получить http: //archive.ubuntu.com/ubuntu/dists/jaunty/ Universe/i18n/Translation-en_IN.bz2 Ошибка чтения с сервера - чтение (104 Сброс соединения по узлу) [IP: 91.189.92.171 80]

W: Не удалось получить http: //archive.ubuntu.com/ubuntu/dists/jaunty/multiverse/i18n/Translation-en_IN.bz2 Ошибка чтения с сервера - чтение (104 сброса соединения по одноранговому узлу) [IP: 91.189.92.171 80 ]

W: Не удалось получить http: //archive.ubuntu.com/ubuntu/dists/jaunty-updates/universe/i18n/Translation-en_IN.bz2 Ошибка чтения с сервера - чтение (104 Сброс соединения по пиру) [IP: 91.189. 92,171 80]

W: Не удалось получить http: //archive.ubuntu.com/ubuntu/dists/jaunty-updates/multiverse/i18n/Translation-en_IN.bz2 Ошибка чтения с сервера - чтение (104 Сброс соединения по узлу) [IP: 91.189. 92,171 80]

W: Не удалось получить http: //security.ubuntu.com/ubuntu/dists/jaunty-security/universe/i18n/Translation-en_IN.bz2 Ошибка чтения с сервера - чтение (104 Сброс соединения по пиру) [IP: 91.189. 92,166 80]

E: Не удалось загрузить некоторые индексные файлы, они были проигнорированы или вместо них использовались старые.

Другие вопросы по тегам