Сервер не пингует внешнюю сеть

Я только что установил Сервер 12.04 на запасной рабочий стол. Все работает хорошо, за исключением случаев, когда я пытаюсь ssh, используя мой внешний IP-адрес.

Файл My / ect / network / interfaces:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.0.5
        netmask 255.255.255.0
        broadcast 192.168.0.255
        network 192.168.0.0
        gateway 192.168.0.1
        dns-nameservers 192.168.0.1

Я тоже пытался использовать dhcp, но все равно не повезло. Я знаю, что сервер может подключаться к внешней сети, потому что он может обновляться, но когда я пытаюсь пропинговать внешний IP-адрес, я не получаю ответных пакетов. Я раньше работал на старых серверах Ubuntu, но никогда не сталкивался с этой проблемой. Я могу с помощью ssh использовать свои внутренние IP-адреса, поэтому обычно я думаю, что это проблема с переадресацией портов, но из-за отсутствия пингов ответа я думаю, что это ошибка конфигурации.

1 ответ

Решение

Я суммирую две разные проблемы из вашего описания

  1. Вы не можете установить SSH подключение с любого внешнего IP-адреса к вашему серверу
  2. После входа на сервер (из внутренней сети) вы все равно не можете пропинговать внешний IP-адрес с сервера.

Так как вы упоминаете переадресацию портов и показываете частный IP на вашем сервере, кажется, что в действии есть NAT/NAPT.

Причины исходящего сбоя пинга и входящего SSH ошибки подключения могут быть разными

  1. ping может быть заблокирован (даже при настройке NAT)
  2. Входящие соединения должны быть перенаправлены через NAT
    • ваш входящий SSH проблемы могут быть такого рода
    • отсутствие этой конфигурации не остановит исходящий перевод и подключение
  3. ты пытался telnet www.google.com 80? или к другому простому HTTP-сайту?
  4. Этот Serverfault вопрос о ping через TCP может быть интересен.
Другие вопросы по тегам