Невозможно обновить Ubuntu Server, так как psa-imp не удаляется

Когда я пытаюсь обновить Ubuntu, используя

apt-get upgrade

Я получаю сообщение

(Чтение базы данных... 67729 файлов и каталогов, установленных в настоящее время.)
Удаление psa-imp ...

Где он будет висеть целую вечность, прежде чем выложит множество ошибок, говорящих о том, что он не может подключиться к базе данных

Действие dpkg: попытка запустить службу mysql... /usr/sbin/mysqld (pid 15949) запущена... выполнено Попытка установить тестовое соединение... ОШИБКА 1045 (28000): доступ запрещен для пользователя 'admin'@'localhost' (используя пароль: YES) ОШИБКА 1045 (28000): доступ запрещен для пользователя' admin '@' localhost '(используется пароль: YES)
ERROR 1045 (28000): доступ запрещен для пользователя' admin '@' localhost '(используется пароль: ДА) ОШИБКА 1045 (28000): доступ запрещен для пользователя 'admin' @ 'localhost' (используя пароль: ДА) ОШИБКА 1045 (28000): доступ запрещен для пользователя 'admin' @ 'localhost' (используя пароль: ДА).... ОШИБКА 1045 (28000): доступ запрещен для пользователя 'admin' @ 'localhost' (с использованием пароля: ДА) ОШИБКА 1045 (28000): доступ запрещен для пользователя 'admin' @ 'localhost' (с использованием пароля: ДА) ОШИБКА 1045 (28000): доступ запрещен для пользователя 'admin' @ 'localhost' (с использованием пароля: ДА) ОШИБКА 1045 (28000): доступ запрещен для пользователя 'admin' @ 'localhost' (с использованием пароля: ДА) не удалось ОШИБКА при попытке установить тестовое соединение Проверьте причину ошибки (см. файл журнала: /tmp/plesk_10.3.0_installation.log), исправьте и попробуйте снова установить тестовое соединение ***** установка отчета о проблеме ***** ОШИБКА при попытке установить тестовое соединение Проверьте причину ошибки (см. файл журнала: /tmp/plesk_10.3.0 _installation.log), исправьте и попробуйте снова установить тестовое соединение. dpkg: обработка ошибок. psa-imp (--remove): установленный подпроцесс. Сценарий после удаления возвратил ошибку. Состояние выхода 1. При обработке возникли ошибки:
 psa-imp
E: подпроцесс /usr/bin/dpkg вернул код ошибки (1)

Я прочитал файл "/tmp/plesk_10.3.0_installation.log", и он не дает никаких подсказок о том, почему процесс не прошел, все, что он показывает, - это подробности действий, ни одно из которых не завершилось неудачей.

Любая помощь?

1 ответ

Решение

Исправлена ​​! Смотрите ссылку ниже, которая помогла мне понять это:

http://forum.parallels.com/showthread.php?t=75882

Похоже, что пароль в теневом файле в /etc/psa/.psa.shadow не совпадает с паролем пользователя 'admin'.

Другие вопросы по тегам