Невозможно запустить гнездо (Невозможно выделить память)
Я хочу использовать PulseAudio поверх разъема, поэтому я отключил пульс и теперь хочу запустить разъем с помощью qjackctl, Однако это приводит к следующему журналу ошибок:
22:14:15.933 Patch Panel disabled
22:14:15.940 Reset statistics.
22:14:15.953 Changed ASLA connection.
22:14:15.970 D-BUS: Service available (org.jackaudio.service aka jackdbus).
Cannot connect to server socket err = File or directory not found
Cannot connect to server socket
jack server is not running or cannot be started
22:14:15.980 Updated visualization of ASLA connections
22:14:18.147 D-BUS: Unable to start JACK server
Cannot connect to server socket err = File or directory not found
Cannot connect to server socket
jack server is not running or cannot be started
Fri Jul 20 22:14:18 2012: Starting jack server...
Fri Jul 20 22:14:18 2012: JACK server starting in realtime mode with priority 10
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Cannot lock down 82246176 byte memory area (Cannot allocate memory)[0m
Fri Jul 20 22:14:18 2012: control device hw:0
Fri Jul 20 22:14:18 2012: control device hw:0
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Failed to acquire device name : Audio0 error : Cannot allocate memory[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Audio device hw:0 cannot be acquired...[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Cannot initialize driver[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: JackServer::Open() failed with -1[0m
Fri Jul 20 22:14:18 2012: [1m[31mERROR: Failed to open server[0m
Fri Jul 20 22:14:19 2012: Saving settings to "/home/jan/.config/jack/conf.xml" ...
22:14:24.418 Cannot connect to JACK server as client - connection failed. See message dialog for details.
Cannot connect to server socket err = File or directory not found
Cannot connect to server socket
jack server is not running or cannot be started
(Несколько сообщений были на немецком языке, я сделал все возможное, чтобы перевести их)
Pulseaudio процесс, безусловно, не работает.
Я использую Ubuntu 12.04 64 бит с аудиокартой NVIDIA.
1 ответ
Хорошо, понял: я должен был добавить себя в группу audio:
usermod -a -G audio theusername
Членство в группах обновляется только при входе в систему, поэтому вам необходимо выйти и войти снова (или просто перезагрузиться).
Быстрая версия: это то, что я добавил в /etc/security/limits.conf, чтобы исправить проблему блокировки памяти; символ @ указывает, что настройки предназначены для группы, а не для пользователя:
user soft rtprio 90
user soft memlock unlimited
@audio hard rtprio 90
@audio hard memlock unlimited
@video hard rtprio 90
@video hard memlock unlimited
Существует простой способ решить проблему: "Не удается заблокировать область памяти размером 82246176 байт". Как правило, блокировка памяти очень мала. Вы можете проверить себя с ulimit -l или для максимального удовольствия ulimit -a, Или максимум информации, если вы ненавидите веселье.
Вы хотите настроить систему так, чтобы ваш пользователь и соответствующие группы могли использовать неограниченную память.
Настройки находятся в /etc/security/limits.conf; файл как таковой ничего не делает, но объясняет ваши варианты. Если ulimit -l не возвращает "безлимитный" после того, как вы последуете моему примеру сверху, что-то не так с вашими настройками в документе.
По поводу вопросов людей о Docker (или snapd, или о любом виде виртуализации), у вас может не хватить свободной памяти или файл конфигурации может быть недоступен для редактирования. Или это может сработать.