Описание тега python-2.7

Python 2.7 - это версия языка программирования Python, выпущенная в 2010 году. Используйте этот тег для вопросов об использовании Python 2.7 в Ubuntu.
1 ответ

Сделать Pycharm по умолчанию для.py файлов в 14.04

Я хочу сделать pycharm ide по умолчанию для всех файлов.py в Ubuntu 14.04. Я извлек файл tar.gz в своем домашнем каталоге, но каждый раз, когда мне нужно запустить pycharm, мне нужно переходить в подкаталог bin и запускать скрипт pycharm.sh. Есть ли…
22 сен '14 в 21:56
2 ответа

Использование определенной версии Python для apt-get в Ubuntu 12.04 LTS

На Ubuntu 12.04 LTS у меня есть python2.7.3-0Ubuntu3.5 пакет установлен. Одна из библиотек, которые я пытаюсь установить, зависит от (>=2.7.3.6). Я пошел вперед и установил python 2.7.6 и даже python --version shows 2.7.6Но когда я бегу apt-get inst…
28 сен '14 в 19:02
0 ответов

Проблемы с пипсом после обновления 12.02->14.04

В Ubuntu 14.04 LTS многие, но не все команды pip терпят неудачу: # sudo pip install --upgrade distribute Downloading/unpacking distribute Downloading distribute-0.7.3.zip (145kB): 145kB downloaded Downloading/unpacking setuptools>=0.7 (from distr…
29 сен '14 в 06:18
1 ответ

Будет ли безопасно использовать python 2.7 в Ubuntu 18.04 после python 2 EOL?

Ubuntu 18.04 по-прежнему будет поддерживаться после 2020 года, но Python 2.7 достигнет конца своей жизни. Если CVE или ошибка возникает для Python 2.7 после 2020 года, получит ли пакет Ubuntu официальное исправление (через APT)? Будет ли какой-либо …
15 авг '18 в 14:26
1 ответ

Ubuntu 18.04 vim-gtk с поддержкой python2

Мне нужен vim-gtk с поддержкой python2 по убутну 18.04. В Ubuntu 16.04 я использовал пакет vim-gtk-py2, но я не вижу эквивалентного пакета 18.04. Кто-нибудь знает о пакете vim с поддержкой python2?
20 авг '18 в 21:02
1 ответ

Запуск программ / приложений

Как запустить / запустить Python после загрузки? Я новичок в Linux и Ubuntu, поэтому мне нужны некоторые указатели. Я так долго болел МС, что думаю, что меня промыли мозги!
13 ноя '14 в 22:08
2 ответа

Как установить numpy и scipy для python 2.7.12, Ubuntu 16.04?

Я попытался установить NumPy с помощью: pip install numpy Это сработало, но я получил предупреждение: warnings.warn(warning, RequestsDependencyWarning), Затем я попытался установить scipy с помощью: python -m pip install --user scipy и это сработало…
08 сен '18 в 12:37
1 ответ

Поддерживает ли opencv3 параметр measureMatrix для фильтра Калмана?

Я использую Ubuntu 16.04, python 2.7.12, и я установил версию opencv 2.4.9.1. Я пытаюсь запустить код для фильтра Калмана и получаю следующую ошибку: AttributeError: у объекта 'cv2.KalmanFilter' нет атрибута 'measureMatrix' Нужно ли устанавливать op…
09 сен '18 в 14:09
1 ответ

Импортированная общая библиотека не относится к плагину

Я создал файл test.so с библиотекой, связанной с этим (DijSDK.h) Поток test.so использует ---- DijSDK.h, который inturn вызывает ---- libsynthcam.so(плагин) файл Теперь я импортирую этот.so файл в мою командную строку python. Который не может связат…
24 ноя '14 в 10:42
1 ответ

Как установить Pygame в Python 2.7.6 на Ubuntu 14?

Как я могу установить Pygame в Python 2.7.6 на Ubuntu 14? Я использовал sudo apt-get install python-pygame, но это не работает и дает мне следующее сообщение: unable to locate package python-pygame, Что мне теперь делать?
02 дек '14 в 15:21
2 ответа

Как заставить программу использовать Python2.7 вместо Python3.4 по умолчанию в Ubuntu 14.04

Я использую Ubuntu 14.04, и у меня есть программа, которая зависит от Python 2.7 и не поддерживает Python 3.x. Ubuntu 14.04 поставляется с python3.4 по умолчанию. Я хотел бы знать, есть ли возможность заставить мою программу использовать python2.7 в…
03 дек '14 в 14:37
1 ответ

Удаление idle-python2.7 в Ubuntu 12.04

У меня возникают некоторые проблемы при обновлении пакетов в Ubuntu 12.04: Processing triggers for menu ... Errors were encountered while processing: idle-python2.7 Setting up idle-python2.7 (2.7.3-0ubuntu3.5) ... Traceback (most recent call last): …
1 ответ

Управление пакетами прервано, много ошибок "[Errno 2] Нет такого файла или каталога"

Вчера пытался обновить драйверы intel и перезагрузился. Я не помню и не имею команд, которые использовал, но после перезагрузки я не смог установить какое-либо программное обеспечение или попытаться исправить мой компьютер. Я все еще относительно но…
1 ответ

BeautifulSoup4 на Ubuntu 14.04 с Python 2.7.6

Я установил bs4 используя apt-get install python-bs4 Когда я пытаюсь запустить скрипт: import urllib2 import bs4 url = "http://rads.stackoverflow.com/amzn/click/B007C9N4H8" web_page = urllib2.urlopen(url) page_text = web_page.read() soup = bs4.Beaut…
10 янв '15 в 20:56
2 ответа

Как обновить версию Python на Ubuntu 14.10

Я пытаюсь выяснить, какую версию Python я установил, а также обновить ее до последней версии. Когда я захожу в командную строку и проверяю, похоже, у меня установлена ​​старая версия python. [email protected]:~$ python Python 2.7.8 (default, Oct 20 2014, …
12 янв '15 в 20:07
1 ответ

Невозможно импортировать pcl в python?

Я следовал инструкциям, приведенным здесь http://www.pointclouds.org/downloads/linux.html. Что нужно сделать после установки libpcl, чтобы импортировать его в python?
29 янв '15 в 09:42
1 ответ

Восстановите Python по умолчанию в Ubuntu 12.04

Я полностью осознаю, что вопрос подобного характера задавался раньше. Но ответ там не приносит никакой пользы для меня. Я установил Python 2.7.6 в дополнение к системе по умолчанию 2.7.3. И теперь моя система облажалась полностью. Теперь я хочу удал…
13 фев '15 в 18:00
1 ответ

Я удалил python2 и python3; Терминал не запустится сейчас!

Я все еще обхожу Ubuntu и Терминал. Я немного знаю Python, поэтому решил, что смогу установить последнюю стабильную версию Python. Когда я запустил python в терминале, он запустил Python 2.7.3, поэтому я подумал, что Python 3.5.2 не был установлен. …
03 авг '16 в 16:15
0 ответов

scikits.audiolab и libsndfile

Я хотел бы спросить, как установить libsndfile для python3 без использования команды sudo. Я даже пробовал команды conda, такие как: conda install -c conda-forge libsndfile и conda install -c conda-forge/label/gcc7 libsndfile На самом деле libsndfil…
02 янв '19 в 09:14
1 ответ

При установке rethinkdb я получаю некоторую ошибку сокета.. как преодолеть эту ошибку

При установке rethinkdb я получаю ошибку сокета. Как я могу исправить ошибку? Я старался: $rethinkdb error: TCP socket creation failed for port 29015: Address already in use.
04 ноя '15 в 06:16