Как установить gmic на 16.04. Ошибка: gmic: Зависит: libcurl4, но не устанавливается

Пытаюсь установить gmic 16.04. Я пытался следовать инструкциям здесь, в которых явно упоминается 16.04, но получаю:

gmic : Depends: libcurl4 but it is not installable

Есть ли способ установить gmic на 16.04?


cat /etc/apt/sources.list|grep -v \#

deb http://gb.archive.ubuntu.com/ubuntu/ xenial main restricted

deb http://gb.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

deb http://gb.archive.ubuntu.com/ubuntu/ xenial universe
deb http://gb.archive.ubuntu.com/ubuntu/ xenial-updates universe

deb http://gb.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

deb http://gb.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
deb https://packages.microsoft.com/repos/vscode stable main

1 ответ

Все хорошо с вашим sources.list. Но я обнаружил, что libcurl4 не поддерживается в Ubuntu 16.04.

Итак, я могу придумать два пути:

1) Установить libcurl3сказано, что он заменит libcurl4:

sudo apt install libcurl3

А потом попробуйте еще раз.

2) Если это не работает, то вам придется вручную установить libcurl4:

wget http://security.ubuntu.com/ubuntu/pool/main/c/curl/libcurl4_7.58.0-2ubuntu3.8_amd64.deb
sudo apt remove libcurl3
sudo dpkg -i libcurl4_7.58.0-2ubuntu3.8_amd64.deb

Примечание: эти программы, такие как php, cmake, feh, curl зависит libcurl,

Если этот способ также не работает, вы должны понизить версию libcurl в libcurl3 (восстановить стабильность). Тогда единственный оставшийся путь - это обновление до Ubuntu 18.04.

Другие вопросы по тегам