Зависимости пакетов не могут быть разрешены при установке кодовых блоков

Всякий раз, когда я пытаюсь установить кодовые блоки, я получаю эту ошибку:

Следующие пакеты имеют неудовлетворенные зависимости:

 codeblocks : Depends: codeblocks-common (= 12.11-3) but it is not going to be installed

2 ответа

Сначала установите codeblocks-common, а затем установите codeblocks.

Вам нужно сначала установить codeblocks-common. Вы можете сделать это либо через Ubuntu Software Center, либо через терминал, используя следующую команду

sudo apt-get install codeblocks-common

или вы можете обработать неудовлетворенные зависимости с помощью следующей команды

sudo apt-get -f install
Другие вопросы по тегам