Обновление не удалось из-за blcr-dkms

Когда я пытаюсь обновить установку Ubuntu 10.04 до 10.10, я получаю следующую ошибку.

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
Trying to install blacklisted version 'blcr-dkms_0.8.2-13'

 This can be caused by:
 * Upgrading to a pre-release version of Ubuntu
 * Running the current pre-release version of Ubuntu
 * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.

Ни один из трех не относится ко мне (я думаю).

Теперь я обнаружил, что это также влияет на кого-то еще: https://bugs.launchpad.net/update-manager/+bug/657662

Здесь есть кто-то, кто знает, что может быть не так? Или обходной путь, чтобы я мог установить Maverick Meerkat?

5 ответов

Решение

Основано на хорошем предложении PocketSam

Смотреть с aptitude why blcr-dkms почему пакет установлен, и удалите этот пакет, если это возможно. Для меня это был пакет r-cran-rmpi который я на самом деле не использую, но установлен с apt-get install r-cran-* команда.

Не забудьте сделать apt-get autoremove чтобы действительно удалить пакет blcr-dkms автоматически.

Причина, по которой этот пакет не работает, объясняется здесь

Может быть, вы можете попробовать удалить этот модуль с помощью dkms?

sudo dkms uninstall blcr-dkms 
sudo dkms remove -all blcr-dkms

Понятия не имею, сломается ли что-то. BLCR (контрольная точка / перезапуск лаборатории Беркли) позволяет программам, работающим в Linux, быть "контрольными" (записанными полностью в файл), а затем "перезапускаться".

Я получил то же сообщение, но когда я попытался в третий раз, используя sudo update-manager -d, это сработало...

Я получал эту ошибку, но она, кажется, решена после того, как я сделал

sudo apt-get install blcr-dkms

Используйте Synaptic и просто удалите blcr-dkms пакет.

Другие вопросы по тегам