Ubuntu-Make 16.11.1 не имеет опции IDE в Ubuntu 17.10 XFCE

Aloha!

Я недавно установил Ubuntu 17.10 Artful с XFCE на свой Samsung Chromebook, и после установки Java JDK 8 я попытался установить Eclipse или IDE Idea intellij.

После попытки вручную установить eclipse некоторое время безуспешно, и по умолчанию была версия 3.8, которая не поддерживает Java 8, я решил попробовать Ubuntu-Make.

После установки umake через apt-get по умолчанию, а также через прямой PPA, я могу загрузить версию 16.11.1. Однако, когда я пытаюсь выполнить команды для затмения или идеи, я получаю сообщение об ошибке, в котором говорится, что опция "ide" недопустима. Отправка команды umake --help показывает, что kotlin и scala являются единственными доступными опциями.

Мой Chromebook работает на ARM.

У меня вопрос: как я могу добавить "библиотеку" IDE в umake, ИЛИ если есть способ вручную установить intellij без использования umake (я знаю, что в eclipse нет поддержки ARM, поэтому я думаю, что ее нет).

Ubuntu-Make: 16.11.1

(xfce)michael@localhost:~$ umake ide idea
usage: umake [--help] [-v] [-r] [--version] {kotlin,scala} ...
umake: error: argument category: invalid choice: 'ide' (choose from 'kotlin', 'scala')

(xfce)michael@localhost:~$ java -version
openjdk version "1.8.0_171"
OpenJDK Runtime Environment (build 1.8.0_171-8u171-b11-0ubuntu0.17.10.1-b11)
OpenJDK 64-Bit Server VM (build 25.171-b11, mixed mode)

(xfce)michael@localhost:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 17.10
Release:    17.10
Codename:   artful

0 ответов

Другие вопросы по тегам