LetsEncrypt - "Не удается подключиться к клиенту для DV"

Я использую LetsEncrypt на Ubuntu 15.10.

Я открыл порты 443 а также 80 использую UFW и могу получить доступ к домену (akuk.co.uk). Я пытаюсь обезопасить себя в веб-браузерах от HTTP.

При запуске ./letsencrypt-auto Команда и выбрав домены (akuk.co.uk и www.akuk.co.uk), я получаю следующее сообщение:

Неудачная процедура авторизации. www.akuk.co.uk (tls-sni-01): urn:acme:error:connection:: Серверу не удалось подключиться к клиенту для DV:: Не удалось подключиться к хосту для вызова DVSNI

ВАЖНЫЕ ЗАМЕТКИ:

  • Следующие ошибки 'urn:acme:error:connection' были обнаружены сервером:

    Домены: www.akuk.co.uk
    Ошибка: серверу не удалось подключиться к клиенту для DV


Бег ./letsencrypt-auto --verbose, Я вижу:

Генерация ключа (2048 бит):
/etc/letsencrypt/keys/0026_key-letsencrypt.pem
Создание CSR: /etc/letsencrypt/csr/0026_csr-letsencrypt.pem
Запуск нового HTTPS-соединения (1): acme-v01.api.letsencrypt.org
Запуск нового HTTPS-соединения (1): acme-v01.api.letsencrypt.org
Запуск нового HTTPS-соединения (1): acme-v01.api.letsencrypt.org
Выполнение следующих задач:
tls-sni-01 вызов для akuk.co.uk
tls-sni-01 вызов для www.akuk.co.uk
Включен модуль Apache ssl
В ожидании подтверждения...
Запуск нового HTTPS-соединения (1): acme-v01.api.letsencrypt.org
Запуск нового HTTPS-соединения (1): acme-v01.api.letsencrypt.org
Запуск нового HTTPS-соединения (1): acme-v01.api.letsencrypt.org
Запуск нового HTTPS-соединения (1): acme-v01.api.letsencrypt.org
Сообщение пользователю: следующие ошибки 'urn:acme:error:connection'
были сообщены сервером:
Домены: www.akuk.co.uk
Ошибка: серверу не удалось подключиться к клиенту для DV
Очистка проблем


мой ports.conf файл выглядит так:

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80

<IfModule ssl_module>
        Listen 443
</IfModule>

<IfModule mod_gnutls.c>
        Listen 443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

sites-enabled файл akuk-co-uk.conf выглядит так:

<VirtualHost *:80>
        ServerAdmin [email protected]
        ServerName www.akuk.co.uk
        ServerAlias akuk.co.uk
        DocumentRoot /var/www/html/akuk_co_uk/public_html

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

# Server Settings for Port 443 (SSL)
<VirtualHost *:443>
        ServerAdmin [email protected]
        ServerName www.akuk.co.uk
        ServerAlias akuk.co.uk
        DocumentRoot /var/www/html/akuk_co_uk/public_html
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

С портами 80 а также 443 открыто, я не могу понять проблему; как это можно исправить?

1 ответ

Решение

Решение было перенаправить порт *:443 на моем маршрутизаторе с соответствующим IP в моей сети (192.168.0.23, в моем случае)

Другие вопросы по тегам