Не удается установить g++ в Ubuntu 13.10 из-за сломанных пакетов

Когда я пытаюсь установить g++ на мою машину, я получаю следующее сообщение.

support:/$ sudo apt-get install g++
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 g++ : Depends: gcc (>= 4:4.8.1-2ubuntu3) but it is not going to be installed
       Depends: g++-4.8 (>= 4.8.1-4~) but it is not going to be installed
       Depends: gcc-4.8 (>= 4.8.1-4~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Я использую Ubuntu 13.10(Saucy). Я застрял с этой проблемой в течение 2 дней. Я знаю, что это дублирующий вопрос, но все же я публикую его, потому что не смог найти решение по другим аналогичным постам.

Я перепробовал все решения, указанные в Пакетной системе не работает. Как это исправить?, Но это не могло решить проблему.

Как и просили в комментарии в https://Ask-ubuntu.ru/questions/385008/cant-install-g-on-13-10-dependency-problem, я выкладываю результат apt-cache policy g++ g++-4.8 ниже

g++:
  Installed: (none)
  Candidate: 4:4.8.1-2ubuntu3
  Version table:
     4:4.8.1-2ubuntu3 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
g++-4.8:
  Installed: (none)
  Candidate: 4.8.2-1ubuntu1
  Version table:
     4.8.2-1ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu/ saucy/main i386 Packages
     4.8.1-10ubuntu8 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages

PS: я не ищу какой-либо конкретной версии g++. Фактический рабочий сценарий: я хочу установить пакет npm 'libxmljs', который зависит от 'node-gyp'. Для правильной установки 'node-gyp' система должна иметь 'make', 'g++' и 'python'. У меня есть make и python в моей системе. Вот что я получаю, когда бегу g++ --version

The program 'g++' can be found in the following packages:
 * g++
 * pentium-builder
Try: sudo apt-get install <selected package>

Пожалуйста, помогите мне решить проблему.

3 ответа

Решение

Подробное решение о том, как решить проблему с поврежденным пакетом, можно найти здесь. Как разрешить неудовлетворенные зависимости после добавления PPA?

Если вы не смогли решить проблему с разбитым пакетом, используя решения, приведенные в ссылке выше, вы можете использовать "aptitude" вместо "apt". Пожалуйста, используйте следующие команды для решения проблемы.

sudo apt-get install aptitude

sudo aptitude install build-essential

Попробуй с

sudo apt-get install build-essential 

это даст все остальное, что вам может понадобиться в будущем при выполнении компиляции.

Вы включили сломанные PPA. Избавьтесь от них, удалите из них установленные пакеты и попробуйте снова.

Другие вопросы по тегам