Ошибка при попытке установить MSGPACK

Я пытаюсь установить MSGPACK для использования с PHP, следуя руководству вики.

Но когда я бегу sudo ./configure Я получаю эту ошибку:

checking PHP version... configure: error: need at least PHP 5 or newer

Когда я бегу: php -v:

PHP 5.3.5-1ubuntu7.2 with Suhosin-Patch (cli) (built: May 2 2011 23:18:30)

Любая помощь?

1 ответ

Хотя у вас может быть установлен интерпретатор PHP, скрипт configure, вероятно, ищет файлы, необходимые для компиляции новых модулей расширения PHP. Эти файлы находятся в php5-dev Установите php5-dev пакет. Попробуйте установить это?

sudo apt-get install php5-dev
Другие вопросы по тегам