Обновлен PHP с 5.4 до 5.6, но phpinfo по-прежнему показывает 5.4

Мой сервер Ubuntu 12.04 LTS использовал PHP 5.4. Затем я обновил до PHP 5.6 с помощью этого Как мне обновить версию PHP до последней стабильной выпущенной версии? инструкция. В процессе установки ошибки не отображаются, перезагрузите сервер.

php -v шоу

PHP 5.6.24-1+deb.sury.org~precise+1 (cli) 

phpinfo шоу 5.4.45-4+deprecated+dontuse+deb.sury.org~precise+1

dpkg -l '*php5*' выход:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                       Version                    Description
+++-==========================-==========================-====================================================================
ii  libapache2-mod-php5        5.4.45-4+deprecated+dontus server-side, HTML-embedded scripting language (Apache 2 module)
un  libapache2-mod-php5.6      <none>                     (no description available)
un  libapache2-mod-php5filter  <none>                     (no description available)
un  libow-php5                 <none>                     (no description available)
ii  php5                       5.4.45-4+deprecated+dontus server-side, HTML-embedded scripting language (metapackage)
un  php5-cgi                   <none>                     (no description available)
ii  php5-cli                   5.4.45-4+deprecated+dontus command-line interpreter for the php5 scripting language
ii  php5-common                5.4.45-4+deprecated+dontus Common files for packages built from the php5 source
ii  php5-curl                  5.4.45-4+deprecated+dontus CURL module for php5
ii  php5-fpm                   5.4.45-4+deprecated+dontus server-side, HTML-embedded scripting language (FPM-CGI binary)
ii  php5-gd                    5.4.45-4+deprecated+dontus GD module for php5
un  php5-gpib                  <none>                     (no description available)
un  php5-idn                   <none>                     (no description available)
ii  php5-intl                  5.4.45-4+deprecated+dontus internationalisation module for php5
un  php5-json                  <none>                     (no description available)
ii  php5-mcrypt                5.4.45-4+deprecated+dontus MCrypt module for php5
un  php5-mhash                 <none>                     (no description available)
ii  php5-mysql                 5.4.45-4+deprecated+dontus MySQL module for php5
un  php5-mysqli                <none>                     (no description available)
un  php5-mysqlnd               <none>                     (no description available)
ii  php5-pgsql                 5.4.45-4+deprecated+dontus PostgreSQL module for php5
ii  php5-readline              5.4.45-4+deprecated+dontus Readline module for php5
un  php5-suhosin               <none>                     (no description available)
ii  php5.6                     5.6.24-1+deb.sury.org~prec server-side, HTML-embedded scripting language (metapackage)
un  php5.6-calendar            <none>                     (no description available)
un  php5.6-cgi                 <none>                     (no description available)
ii  php5.6-cli                 5.6.24-1+deb.sury.org~prec command-line interpreter for the PHP scripting language
ii  php5.6-common              5.6.24-1+deb.sury.org~prec documentation, examples and common module for PHP
un  php5.6-ctype               <none>                     (no description available)
un  php5.6-exif                <none>                     (no description available)
un  php5.6-fileinfo            <none>                     (no description available)
ii  php5.6-fpm                 5.6.24-1+deb.sury.org~prec server-side, HTML-embedded scripting language (FPM-CGI binary)
un  php5.6-ftp                 <none>                     (no description available)
un  php5.6-gettext             <none>                     (no description available)
un  php5.6-iconv               <none>                     (no description available)
ii  php5.6-json                5.6.24-1+deb.sury.org~prec JSON module for PHP
ii  php5.6-opcache             5.6.24-1+deb.sury.org~prec Zend OpCache module for PHP
un  php5.6-pdo                 <none>                     (no description available)
un  php5.6-phar                <none>                     (no description available)
un  php5.6-posix               <none>                     (no description available)
ii  php5.6-readline            5.6.24-1+deb.sury.org~prec readline module for PHP
un  php5.6-shmop               <none>                     (no description available)
un  php5.6-sockets             <none>                     (no description available)
un  php5.6-sysvmsg             <none>                     (no description available)
un  php5.6-sysvsem             <none>                     (no description available)
un  php5.6-sysvshm             <none>                     (no description available)
un  php5.6-tokenizer           <none>                     (no description available)

Что я должен сделать, чтобы apache2 использовал правильную версию PHP, которую я хотел - 5.6?

Спасибо

1 ответ

Как dpkg -l вывод показывает, ваш Apache PHP модуль (пакет libapache2-mod-php5) находится на версии 5.4. Вы должны установить пакет libapache2-mod-php5.6, который установит версию 5.6. Может быть необходимо сначала удалить libapache2-mod-php5, (Вы, вероятно, также хотите удалить все остальные php5-* пакеты, которые относятся к PHP 5.4, но это не обязательно.)

Другие вопросы по тегам