Как получить IPv4-адрес сервера Ubuntu, работающего в виртуальной коробке вместе с IPv6?

Я установил Ubuntu Server на виртуальной коробке. Когда я выполняю команду "ifconfig", она показывает информацию о eth0 и loopback с адресом inet6. Но я хочу адрес ipv4 вместо ipv6, и я не уверен насчет конфигурации сетевого адаптера virtual box, поскольку я использую Wi-Fi на моем компьютере. пожалуйста, помогите мне

3 ответа

Решение

Как я могу догадаться, вы сделали режим моста для Интернета, но ваш DHCP не предоставил IP-адрес для вашего порта, или вы не включили сеть. Итак, это показывает, как это

eth0      Link encap:Ethernet  HWaddr e8:11:32:db:1b:a5  
          inet6 addr: fe80::ea11:32ff:fedb:1ba5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:68323 errors:0 dropped:0 overruns:0 frame:0
          TX packets:51953 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:82498217 (82.4 MB)  TX bytes:4621046 (4.6 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:9075 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9075 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:916870 (916.8 KB)  TX bytes:916870 (916.8 KB)

Решение: запустите свой сетевой менеджер, используя

sudo service network-manager start

или используйте, если уже начали

sudo service network-manager restart

или же

sudo ip link set eth0 up 

или же

sudo nmcli nm enable true

или включите использование GUI

network-manager--> Enable Networking and connect wired connection

или же

если проблема не устранена, значит, ваш Wi-Fi dhcp не предоставляет IP-адрес виртуальной машине, тогда вы можете изменить режим bridge в NAT за интернет, тогда вы получите частный IP и сможете подключить интернет

Помимо режима моста, я должен был отключить ipv6 согласно этому посту, чтобы заставить его работать: https://superuser.com/questions/1146122/ubuntu-virtualbox-guest-does-not-get-ipv4-in-bridged-mode/1148247

Вставка шагов сверху: Открыть /etc/default/grub

В этом файле найдите эту строку:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

и измените его на:

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash"

Сохраните файл и обновите GRUB, запустив:

sudo update-grub

Теперь перезагрузите ВМ. В следующий раз придет соответствующий IPv4-адрес.

Не могли бы вы убедиться, что вы настроили свой виртуальный интерфейс в режиме моста?

Если вы используете беспроводное соединение, Vbox не будет поддерживать IPv6 в мостовом режиме, как вы можете видеть в руководстве по Vbox:

https://www.virtualbox.org/manual/ch06.html

Надеюсь это поможет.

Другие вопросы по тегам